lundi 21 juin 2010

CPANTester journey - setting up virtual environment (en/fr)

My initial intent was too install VmWare Server (which is free (as beer), and that I used a long time ago with great satisfaction) on my Ubuntu boxes.

But as it appeared that my kernel (and all kernels 2.6.30 and above) now requires an unofficial additional patch to fix the VmWare Server installer*, I decided to play it safe (or at least simple) and install the VmWare Player 3.1.0 instead.
* See http://communities.vmware.com/thread/215985 for more information

The VmWare Player install went fine, and installing an XP virtual machine was just a matter of minutes.

For some reason NAT was not working out of the box, so I only changed the VM network setting to Bridge and was then able to download Strawberry Perl 5.12.0.1.
Sadly my attempt to install also release 5.10.1.2 in the same VM failed miserably (the installer detecting an higher version)...
If anyone managed to get (simply) 2 version on the same Windows box, I'd be glad to hear how...


Now I still have to install the modules needed for testing, but it will be another post...

[French Translation]


Mon intention initial était d'installer VmWare Server (qui est gratuit, et que j'avais utilisé il y a longtemps avec beaucoup de satisfaction) sur mes machines Ubuntu.

Mais comme il apparait que mon noyau (et tous les noyaux 2.6.30 et au dessus) nécessitent maintenant un patch additionnel non-officiel pour corriger l'installeur de VmWare Server, j'ai décidé de jouer la sécurité (ou au moins la simplicité) et d'installer VmWare Player 3.1.0 à la place.
* Voir http://communities.vmware.com/thread/215985 pour plus d'informations

L'installation de VmWare s'est bien déroulée, et l'installation de machines virtuelles XP a juste pris quelques minutes.

Pour une raison inconnue le NAT ne fonctionnait pas en l'état, j'ai donc juste changé la configuration réseau de la VM en bridge et j'ai pu télécharger Strawberry Perl 5.12.0.1.
Malheureusement ma tentative d'installer aussi la version 5.10.1.2 dans la même VM a échoué lamentablement (l'installeur détectant une version plus avancée)...
Si quelqu'un à réussi à avoir (simplement) 2 versions sur la même machine windows, je serai heureux d'apprendre comment.

Maintenant je dois encore installer les modules requis pour tester, mais ça sera un autre post...

Aucun commentaire :